Odpowiedzi

2010-01-25T18:37:23+01:00
Nie mam pojęcia, czy o to biega, bo pierwszy raz coś takiego widzę. Jest to kod zarejestrowanego makra, które w A1 pobiera wartość, w B1 testuje tą wartość przy pomocy funkcji ZNAK.LICZBY. Funkcja ta zwraca 1, gdy liczba jest dodatnia, -1, gdy ujemna. Jeżeli wpiszemy zero to zwraca 0, jednak tą opcję pominęłam i zrobiłam tak jak w poleceniu, czyli, jeśli dodatnia -wypisujemy dodatnia, a jeśli inny przypadek-wypisujemy- ujemna (czyli zero będzie tez wypisywane, jako ujemna). W komórce C1, przy użyciu takiego ifa excelowego sprawdzamy wartość z B1 i wypisujemy po prostu tekst, w zależności od wartości ;p
=JEŻELI(B1=1;"Dodatnia";"Ujemna"), czyli jeśli funkcja z B1 zwraca jeden wypisz dodatnia, w przeciwnym wypadku wypisz ujemna:) i tyle, ale serio nie wiem czy o to chodzi

Sub wartosc()
Range("B1").Select
ActiveCell.FormulaR1C1 = "=SIGN(RC[-1])"
Range("C1").Select
ActiveCell.FormulaR1C1 = "=IF(RC[-1]=1,""Dodatnia"",""Ujemna"")"
End Sub