Należy wykonać skalowalny pejzaż w okolicach środka ekranu zawierający domek, co najmniej 4 różnej wielkości drzewa oraz słońce. Logmocja... Zrobiłem domek i choinnke trzeba jeszcze zrobic słońce i zrobić z tego pejzaż
oto choinka :a
lw 135 np :a*2.1 lw 135
np :a pw 135 np :a*2.4
lw 135 np :a pw 135
np :a*2.5 lw 135 np :a*2.5 pw 90
np :a lw 90 np :a
lw 90 np :a pw 90
np :a*2.5 lw 135 np :a*2.5
pw 135 np :a lw 135 np :a*2.4
pw 135 np :a lw 135 np :a*2.2
pw 45

już

oto Domek :x
np :x
lw 90
np :x
lw 90
np :x
lw 90
np :x
ws :x/3
lw 90
np :x/3
lw 90
np :x/3
lw 90
np :x/3
pod
ws :x/2
opu
pw 90
np :x/6
pw 90
np :x/6
pw 90
np :x/6
pw 90
np :x/6
pod
lw 90
np :x/3
opu
lw 90
np :x/6
pw 90
np :x/6
pw 90
np :x/6
pw 90
np :x/6
pod
ws :x/3
pw 90
np :x/2
lw 45
opu
np :x/3
lw 45
np :x/9
pw 90
np :x/10
lw 90
np :x/10
lw 90
np :x/10
pw 90
np :x/3.13
lw 45
np :x/3
już

2

Odpowiedzi

2009-10-04T18:26:50+02:00
W twojej procedurze domek dopisałem w ostatniej linii:
pw 135 (ustawienie zólwia w poz pion)
już

oto pejzaż :x
domek :x
pod pw 90 np -:x lw 90 np -:x opu
choinka :x/4
pod pw 90 np -:x/5 lw 90 np :x opu
choinka :x/7
pod pw 90 np :x/2 lw 90 np :x/2 opu
choinka :x/12
pod pw 90 np :x*3 lw 90 np -:x*2.5 opu
choinka :x/10
pod pw 90 np :x/8 lw 90 np :x*2.5 opu
sun
już

oto sun
powtórz 36 [np 5 pw 10 lw 90 np 20 ws 20 pw 90]
już

do wywołania należy wpisać np: pejzaż 100

jezeli jakieś uwagi, i propoz - pisz...
2009-10-04T20:17:04+02:00
Pw 135 (ustawienie zólwia w poz pion)
już

oto pejzaż :x
domek :x
pod pw 90 np -:x lw 90 np -:x opu
choinka :x/4
pod pw 90 np -:x/5 lw 90 np :x opu
choinka :x/7
pod pw 90 np :x/2 lw 90 np :x/2 opu
choinka :x/12
pod pw 90 np :x*3 lw 90 np -:x*2.5 opu
choinka :x/10
pod pw 90 np :x/8 lw 90 np :x*2.5 opu
sun
już

oto sun
powtórz 36 [np 5 pw 10 lw 90 np 20 ws 20 pw 90]
już

do wywołania należy wpisać np: pejzaż 100