Program Logomocja. Mam test z wiedzy. Mogę zrobić co mi się podoba. Przerobiliśmy już podstawę czyli żółwia i muzykę. Pomysł należy do Was. Proszę tylko, by było połączenie muzyki z żółwiem ;) Na środę(tylko NIE wieczór!! Na mniej więcej 3-4 lekcję; nie obrażę się jak będzie na wtorek wieczór)

AAA ważne! co do punktów mogę dorzucić trochę!
Sprawiedliwa praca=sprawiedliwa wypłata.

Jeszcze ważniejsze!! Nie będę spamował!

1

Odpowiedzi

Najlepsza Odpowiedź!
2010-02-16T16:41:35+01:00
Zrób to polecam
oto SERWETKI.ODWR :n :prom :krok
; ładne: [4 150 4][5 98 4][9 80 4][18 80 4]
niech "kąty 360 / :n
niech "rozm 2 * :prom * sin ( :kąty / 2 )
pod np :prom pw 90 + ( :kąty / 2 ) opu
powtórz :n [BOKI.ODWR :rozm pw :kąty]
pod lw 90 + ( :kąty / 2 ) ws :prom opu
już

oto BOKI.ODWR :rozm
jeśli :rozm < :krok [np :rozm stop]
BOKI.ODWR :rozm / 3 pw 180 - :kąty
BOKI.ODWR :rozm / 3
powtórz :n - 2 [lw :kąty BOKI.ODWR :rozm / 3]
pw 180 - :kąty BOKI.ODWR :rozm / 3
już

Żeby wywołać procedurę rysującą taką rozetę należy wpisać SERWETKI.ODWR 9 85 3.
Lekcja 2
oto kw

opu
repeat 4 [ np 40 pw 90 ]
pod
pw 45
np 5
ukm [ 95 173 84 ]
fill
ws 5
pw 45
np 40
lw 90
już

oto kw1

opu
repeat 4 [ np 40 pw 90 ]
pod
pw 45
np 5
ukm [ 173 95 55 ]
fill
ws 5
pw 45
np 40
lw 90
już

oto szachownica
repeat 4 [ repeat 4 [ kw kw1 ] lw 90 np 320 pw 90 np 40 repeat 4 [kw1 kw] lw 90 np 320 pw 90 np 40]
już
Lekcja 3
:Bok - długość boku
:ile - złożoność(stopień) figury

Kod Procedury:
oto dywan :bok :ile
jeśli :ile = 0 [stop]
powtórz 4 [np :bok pw 90]
powtórz 4 [powtórz 3 [dywan :bok / 3 :ile - 1 np :bok / 3] pw 90]
już
Pocwicz to
oto ts :n :bok
jeśli :n = 0 [stop]
powtórz 3 [sierpinski :n - 1 :bok / 2 np :bok pw 120]
Lekcja 4
sztacheta :x (x - wysokość do trójkąta)
plot :x :y (x - ilość sztachet; y - wysokość sztachet)
np. płot 5 100

Kod Procedury:
oto 6kat :bok
powtórz 6 [np :bok pw 360 / 6]
już

oto fraktal :bok :ile
6kat :bok
jeśli :ile = 0 [stop]
powtórz 6 [6kat :bok / 2,5 np :bok / 2 np :bok / 10 6kat :bok / 2,5 np :bok / 2,5 pw 60]
pod np :bok / 2,5 pw 60 np :bok / 2,5 pw 60 np :bok / 2,5 lw 60 ukm 0 np 2 zamaluj ws 2 pw 60 ws :bok / 2,5 lw 60 ws :bok / 2,5 lw 60 ws :bok / 2,5 opu
powtórz 6 [fraktal :bok / 2,5 :ile - 1 np :bok / 2 np :bok / 10 fraktal :bok / 2,5 :ile - 1 np :bok / 2,5 pw 60]
już

Jeszce to
oto koła
ustalgrubośćpisaka 6
ustalkolorpisaka [0 148 255]
lw 90
pod
np 230
pw 90
np 30
lw 90
opu
powtórz 360 [np 2,5 pw 1]
pw 180
pod
np 214,5
opu
pw 180
ustalkolorpisaka 0
powtórz 360 [np 2,5 pw 1]
pw 180
pod
np 214,5
opu
pw 180
ustalkolorpisaka 12
powtórz 360 [np 2,5 pw 1]
pod
np 107,25
lw 90
np 186
pw 90
opu
ustalkolorpisaka 2
powtórz 360 [np 2,5 pw 1]
pod
np 214,5
opu
ustalkolorpisaka [255 234 0]
powtórz 360 [np 2,5 pw 1]
już
okrąg 10 gwiazdka 10 niewiem c jeszcze