Logomocja procedury rekurencyjne.

Mamy podaną procedurę kwadrata:

Procedura: "kwadrat":

oto kwadrat :bok
powtórz 4 [np :bok pw 90]
już

Procedura: "kwadraty":

oto kwadraty :bok :ile
jeśli :ile=0 [stop]
kwadrat :bok
np :bok/2 pw 45
niech "bok 0.5*:bok*pkw 2
kwadraty :bok :ile-1
już

Teraz mam zrobić coś w tym stylu (że ciągle mniejsze w kolejnych) tylko z !! trójkątami !!.

1

Odpowiedzi

2010-02-23T19:23:31+01:00
Oto trojkat :bok
powtórz 3 [np :bok pw 120]
już



oto trojkaty :bok :ile
jeśli :ile=0 [stop]
trojkat :bok
np :bok/2 pw 60
niech "bok 0.5*:bok
trojkaty :bok :ile-1
już
2 3 2