W Excelu do komórki D1 wprowadzona jest dzisiejsza data, a do komórki D3 wprowadzona jest czyjaś data urodzin. Zadanie polega na tym aby obliczyć ile ta osoba ma lat. Szkopuł tkwi w tym, że jeśli dzisiaj jest np. 27.04.2010 a ktoś urodził się 11.11.1961 to nie skończył jeszcze 49 lat więc komórka powinna mi zwracać 48 lat.

Ułożyłam funkcję spełniającą ten warunek, ale jest ona długa. Podobno można to zapisać dużo krócej i właśnie takiego krótkiego zapisu potrzebuję.

Tutaj jest moja funkcja: =JEŻELI(MIESIĄC($D$1)>MIESIĄC(D3);ROK($D$1)-ROK(D3);JEŻELI(ORAZ(MIESIĄC($D$1)=MIESIĄC(D3);DZIEŃ($D$1)>=DZIEŃ(D3));ROK(D$1)-ROK(D3);ROK(D$1)-ROK(D3)-1))

Z góry dziękuję za pomoc :)

1

Odpowiedzi

Najlepsza Odpowiedź!
2010-03-28T17:11:17+02:00
Wiek podany w dniach =DZIŚ()-A1
lub też =DATA.RÓŻNICA(A1;DZIŚ();"D")
wiek w ukończonych miesiącach =DATA.RÓŻNICA(A1;DZIŚ();"M")
wiek w ukończonych latach =DATA.RÓŻNICA(A1;DZIŚ();"Y")
Po drobnych modyfikacjach winno pasować;)