Odpowiedzi

2009-11-06T17:17:04+01:00
Wywołuje się np: osiedle 60 20 4

oto dach :a
skok :a 0
pw 30
ukm jld
wielokąt[
powtórz 3[np :a pw 120]]
lw 30
skok -:a 0
już

oto dom :a
ściana :a
dach :a
już

oto osiedle :a :l :n
skok -:a (-(:a/2+:l)*:n)
powtórz :n[
dom :a
skok 0 (:a+:l)]
już

oto skok :a :b
pod
np :a pw 90 np :b lw 90
opu
już

oto ściana :a
ukm jld
wielokąt[powtórz 4[np :a pw 90]]
już

jeżeli trzeba bardziej zaawansowanie, lub coś wyjaśnić/zmienić/poprawić - pisz.
3 4 3
2009-11-06T19:15:30+01:00
To dom :h
lt 90 fd 50 rt 90 fd :h - 50 rt 90 fd 100 bk 100 lt 45 fd 100 / sqrt 2 rt 90 fd 100 / sqrt 2 rt 45 fd :h - 50 rt 90 fd 50 rt 90
end

to osiedle :h :i :o
cs pu setpos [-200 0] pd repeat :i [pd dom :h pu rt 90 fd 100 + :o lt 90 pd]
end


W j.ang.
Działa, sprawdzone :)
1 5 1